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The Voxel Workflow

In t ro d u c t i o n

The Voxel Workflow is a handbook for creating files in a format
that allows complex colour mixing and the specification of material
properties for polyjet 3D printing.

The voxel workflow differs by approaching the creation of parts
at a droplet level. Rather than creating a 3 dimensional mesh this
method is layer or slice based. Imagine a 3D shape as a stack of
very thin slices with each slice being an image. Looking closer you
would see the image is made up of micro squares of colour, known
as pixels. As each of these pixels are volumetric, they are referred to
as a voxel, and thus is a very small ‘part’ of the overall model.

3

You may be conversant with mesh-based modelling and the output
of .stl file formats which typically follow the convention of parts in
an assembly. For example, a .stl file is a 3-dimensional mesh that
describes a shape, it can only have one colour with one material
property. To afford greater colour and/or material properties the
mesh must be cut and divided, a time consuming and intensive
method.

To explore how this new method works The Voxel Workflow is
broken into two guides. First, The Guide To Voxel where imagery
can become 3 dimensional and 3D printed. Second, The Guide To
Bitmap where the use of medical DICOM data is explained.
The Voxel Workflow is step based and following each step is
imperative. You may find anomalies or failures when creating
files, which may be due to missed steps, incorrect formatting, or
programme updates.
Programmes required are GrabCAD Voxel Print Utility available in
the GrabCAD research package, Adobe Photoshop, 3D Slicer.
Enjoy.

I n t ro d uc t io n

This guidebook was created by Ana Morris, Izzy Robb, and Bernard
Guy and contributed to by Charlotte Horder ©2021

Ana Morris

Ana Morris is an Industrial Designer currently based in Auckland, New
Zealand. Ana recently completed her Master of Design Innovation,
specialising in multi-property and highly realistic 3D-printed medical
modelling. Her thesis “Beneath the Skin: Emulating human physiology
using a novel bitmap-based (voxel) additive manufacturing workflow”
promoted the need to create this guide.

Izzy Robb is currently studying towards her Masters of Design Innovation.
Izzy’s thesis explores the value of medical data as an object. Flowing data
into an object can only be achieved using a voxel approach and the need
for a ‘recipe’ enthused Izzy to contribute to this guide.

The Voxel Workflow

Izzy Robb

Exam pl e Work

During the final evaluation of the Voxel Workflow Charlotte Horder tested
the procedure as a novice. Charlotte applied the workflow to cross sectional
photography of fruit and vegetables, successfully 3D printing The ‘Cuisine’
jewel collection is Summer, Spring, Winter, and Autumn earrings, each
expressed through a 74 layered three dimensional form.
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Charlotte Horder
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STEP BY STEP

Guide to
VOXEL
Guide to VOXEL

OVERVIEW

Key Terms and Definitions
3D PRINTING

a type of additive manufacturing (AM) that builds
a physical object out of a digital blueprint by
depositing sequential two-dimensional (2D) layers
of material in order to create a three-dimensional
(3D) form (Bastawrous et al., 2018, p. 2809).
BITMAP

a type of image (e.g. PNG or JPEG file formats) that
is made up of squares, or ‘pixels’, that form a grid
making up a full image. The smaller the squares
that make up an image, the higher the quality
(resolution) of the image. Each pixel holds colour
data.
B I T M A P- B A S E D “ VOXE L” 3 D PR I N T I N G

a method of AM that can translate information from
various types of bitmap datasets into heterogeneous
physical entities by converting on-screen pixels into
multi-material droplets. These micro-droplets are
also referred to as ‘voxels’ (Bader et al., 2018, p. 2).

1 P N G I m a g e = O n e Voxe l P r i n t L a ye r
one voxel

bitmap image
27-micron voxel 3D print

Guide to VOXEL
VOXEL

a term used to describe a ‘3D-printed pixel’, a
14-micron or 27-micron material droplet.
THE STRATASYS J750™ 3D PRINTER

a full-colour and multi-material Polyjet 3D-printer
manufactured by Stratasys and supplied by the
Victoria University of Wellington. School of Design
Innovation.
AGILUS30 ™

a rubber-like PolyJet photopolymer material that

VERO ™
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can flex and bend.

a rigid PolyJet photopolymer material available in

Voxel Prin t in g

many colours.

OVERVIEW

Bitmap to Voxel Process
HOW DOES VOXEL 3D PRINTING WORK?

A bitmap-based 3D-printing workflow allows image files to be
sent directly to some multi-material 3D-printers, such as the
Stratasys J850™ 3D-Printer for the production of physical forms.
The Stratasys J750™ 3D-Printer can 3D-print one image on top of
another. When images are deposited sequentially on top of each
other, the 3D-printer can construct a tangible 3D model. Each
image sent to the 3D-printer contains a pixel matrix inspired by
error-diffusion algorithms from 2D-printing.
Due to the limited amount of 3D-printer primary colours,
additively manufactured shades and gradients can only be
produced through 2D-printing Halftoning principles. So, just
like a printed photograph which is comprised of many pixels,
a 3D-print made up of many voxels can be observed as a
homogenous area with blended materials.

Part-based 3D Printing

Usually, one part (STL, OBJ, Mesh) = One material
Voxe l P r i n t i n g

One material droplet = One material
(printing enables the fabrication of parts with complex material
distribution, such as a gradient or a sophisticated pattern)

Voxel Prin t in g Wo rk flow
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OVERVIEW

An Example of a Voxel Printing Workflow
Looks kind of complicated right? Turn the page for a step by step tutorial.

Voxel Prin t in g Wo rk flow
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Tutorial

Before you Begin: Considerations
a. WHICH MATERIALS ARE ON THE 3D PRINTER?

You can only have 7 materials on the 3D Printer at a time.
Materials most commonly on the 3D Printer are:
VeroCyan-V™
VeroMagentaV™
VeroYellow-V™
VeroBlackPlus™
VeroPureWhite™
VeroClear™ (hard, clear material)
Agilus30™ (clear-ish bendy material)

However, the following materials can be added if required;
VeroUltraClear™ (a new material, super clear, not common)
Clenser (liquid)

Material changes come with added costs and printing requirements,
please check with the printing technician before creating models with
these materials.
If you want to see if there is a planned material change, check the
Stratasys J850 Google calendar (ask how you can see this or email the
3D print technician for access).

Guide to VOXEL
z axis

VeroMagenta-V

VeroYellow-V

VeroPureWhite

VeroBlackPlus

VeroClear

Agilus30
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VeroCyan-V

Multi material droplets (voxels)

UV cured multi-material 3D print
x axis

y axis

Full Colour

Translucency

Th in g s to Co nside r

Varying Densities

Tutorial

Before you Begin: Considerations

b. WHAT IS THE CHEAPEST ORIENTATION?

The taller your 3D print is on the bed, the more expensive
your 3D print will be. This means further up the z axis will
mean the 3D print is more expensive. You want your 3D
print to be lying down.
If you’re looking down on the 3D Printer bed, you want your
3D print to lie in the upper left corner, towards the top of the
bed (further up the y axis).

Guide to VOXEL
not standing up

Th in g s to Co nside r

aim for this area
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aim for the 3D print to be lying down

Tutorial

1. Data Acquisition

Before 2D halftoning and assigning materials to your voxel 3D print, you need a
dataset (stack of images). These images must be in a folder on your computer.
The end goal is to have a folder full of images on your computer to process.

Guide to VOXEL

WHAT DATASET ARE YOU USING?

To get a dataset you can begin with:

A FORM
(in another program, such as Matlab or Slicer3D, you can
eg. Lungs
(.stl file)

slice the model and generate a set of .PNG image files).
A STACK OF IMAGES
(eg. Images that you curate yourself, an MRI scan, or a CT
scan).

Image Stack
(eg. CT scan)

It is recommended that the layer thickness of the slices you prepare match the
printed layer thickness. The printer layer thickness is:

19

Layer Height (space between images)

• 0.027 mm = High Speed & High Mix
Each image will be 3D printed at 0.027 mm in height (z resolution).
Some files (such as a CT scan will be spaced further apart), which means that

0.3 mm
0.3 mm
0.3 mm

CT scan (0.3 mm slices)

0.027 mm
0.027 mm
0.027 mm
0.027 mm
0.027 mm
0.027 mm
0.027 mm
0.027 mm

Interpolated CT scan (0.027 mm slices)

Pre parin g th e Data

an interpolation function is need to ‘fill in the gaps’.

Tutorial

2. Setting Up a Primarily
Automated Digital Workflow
in Adobe Photoshop

Choose one image from your folder of images and open in Adobe Photoshop.
This image should be one of the images with the most data and/or colour within your data set.

Guide to VOXEL

a. ENTER PHOTOSHOP

Open the image in Photoshop and create an Action
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(Window -> Action -> Create Action)

b. SIZING

Crop your image to the desires selection using the cropping tool.
If your data set has been exported from 3DSlicer, the image size percent will
need to be locked, then changed to 200 for the scale to be 1:1.

The width and height of the image can be changed to achieve desired
proportions, however resizing the print will not impact the height of the image
stack and instead will disproportion your image stack.
If you wish to resize your images, make sure the width and height are locked,
change the unit to millimetres, then resize your image.

P h o to sh o p Batch Pro cess

(Image -> Image size)

c. SETTING THE BACKGROUND

To create a model that has a clear bounding box or clear pathways within the
model, VeroClear material properties need to be assigned.
VeroClear is assigned through RGB values.
R: 227 G: 233, B: 253
(Make a new layer -> Move it to the back -> Set VeroClear setting in Colour Picker
-> Use the paint bucket tool to fill the background with VeroClear -> Merge the two
layers)
Once filled, the background will appear blue tinged, but will print clear.
To print with empty pathways, don’t add any background, instead keep it
transparent.

d. X Y R E S O L U T I O N

The J750 has different resolutions in X and Y.
• X resolution = 600 DPI
• Y resolution = 300 DPI
To meet these parameters, the DPI must be changed.
This must be completed in 2 steps rather than all in 1.
(Image -> Image Size)
a. Unlink width and height
Change unit to percentage
Change width to 200%
Change height to 100%
Save
b. Reopen Image Size
300 DPI
Save

The 3D Printer has to create gradients in material (such as gradients in colour)
out of the materials that are in the 3D Printer (these materials were the ones
you decided on earlier (page 10). If you want to make the colour green, for
example, you will need to mix VeroCyan-V™ and VeroYellowV™ pixels.
How does this work?
Just like the pixels on your TV screen or 2D printing on a normal printer!

Guide to VOXEL

e. MATERIAL ASSIGNMENT (DIGITAL HALFTONING)

zoom

zoom

zoom
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Original Image

P h o to sh o p Batch Pro cess

Index Coloured (Digitally Halftoned)

f. MATERIAL ASSIGNMENT

The colour file must be changed to the colours that are on the J850 rather than
all RGB colours. Load the 7 colours that will be loaded on the J850.
(Image -> Mode -> Indexed Colour)
a.

Change the Palette option to Local
(Perceptual), and Colours to 9 (or
the minimum that you are able to
input).
Change Forced to Custom and
load in the J850 colour table.

b.

Make sure that Transparency is
also checked.
Under Options tick Preserve Exact
Colours.
Press Ok, and Ok to save.

Swap back into RGB colour mode.
(Image -> Mode -> RGB)
These are your machine materials. You
can find the specific RGB values on the
GrabCAD Voxel Print website but below
are what they currently are. Input these
values to assign your colours/materials.

VeroCyan-V™
VeroMagenta-V™
VeroYellow-V™
VeroBlackPlus™
VeroPureWhite™
VeroClear™
Agilus30™

Save your file as PNG in a new folder
(File -> Save As -> PNG -> New Folder)
Choose a new folder where all your index coloured files will save to.
Close the file and choose don’t save to the original file.

Guide to VOXEL

g. SAVING

h. ENDING ACTION

As all steps have been completed, the
recording of actions needs to be stopped.

25

(Window -> Actions -> Stop)

i. AUTOMATING THE BATCH PROCESS

To apply your actions to your stack of images,
it must be batch processed.

P h o to sh o p Batch Pro cess

(File -> Automate -> Batch -> Select recorded action -> Select folder where the original images
are -> Let it run)

Tutorial

3. Renaming in Adobe Bridge

You can do this on Adobe Bridge (batch rename) or manually.
Files must be renamed to ensure compatibility with GrabCAD Voxel Print
Utility, a software add-on for GrabCAD Print

Guide to VOXEL

Once your image stack has been processed and digitally halftoned, you
need to rename your files correctly.

a. RENAME YOUR FILES

Open the folder where all your index coloured images have been saved to.
(Select all images -> Tools -> Batch Rename)
Remove: date and time
Remove: text - _
Remove: Text - Type Text
This should leave you with only Text and Sequence Number.

R en a mi n g File s

If you have more than 100 images, change sequence number to 001 and
Three Digits, if between 10 and 99, start with the sequence number as 01
and Two Digits, rename with declining digits until your data sets starts from
1.
Once the images are selected and the first sequence is renamed, select
the next set of images (1 - 99, or 1 - 9) and redo the steps, this time making
the extension 01 and 2 digits, then 1 and one digit.
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Change Text to your chosen file name, followed by _ (eg. Image_).

Tutorial

4. GrabCAD

Voxel Utility Print must be used to stack PNG’s to print as a 3-dimensional
model.
(Apps -> Launch Voxel Print Utility)
Add the name you called your images during the bridge steps (eg. Image_),
then choose the folder where they are located.

Guide to VOXEL

a. LOADING YOUR FILES

If the background was made to be VeroClear, leave Red, Green, and Blue as
0, and Alpha as 255.
If the background was left transparent for empty pathways, change the
Red, Green, and Blue to 255, and Alpha to 0.

When selecting the colours that will be included in your model, the
program will automatically detect which colours it needs to use to print
your model. Change the names of the chosen colours to ensure they are
the correct ones that correspond with the printer.
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b. SELECTING COLOURS

G rab CAD

Cyan - VeroCY-V
Black - VeroBlack
Magenta - VeroMGT-V
Clear - VeroClear
Yellow - VeroYL-V
White - VeroPureWht
Agilus - Agilus30White

Ch ap ter N am e
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STEP BY STEP

Guide to
Bitmaps
Guide to VOXEL

Tutorial

5. 3D Slicer

Open 3DSlicer and either import your own data, or use the sample data under
‘Download Sample Data’ on the home page. Pick the set of data you wish to
use, choosing between CT or MRI data.
(Drop down menu -> Sample Data -> Volume Rendering)

Guide to Bitmaps

a. IMPORTING DATA

b. VIEWING YOUR DATA

Enable the 3D view by clicking the eye next to Volume.
nents within your data.
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Select a preset that you wish to use. Each present displays different compo-

(Display -> Select a preset)
Display your data on screen for editing.
(Crop: Enable -> Display ROI)
Before cropping your data, you may need to reorient it to ensure it is cost effec-

3 D Sli cer

tive for printing.

c . ORIENTATION

If you’re wanting a vertical slice from your model, the model needs to be
changed to be lying horizontal. This is so that when inserted into GrabCAD it is
the right orientation, and is the most cost effective.
The orientation cannot be altered once the model is created.
(Drop down menu -> Sample Data -> Volume Rendering)
a. (Drop down menu -> Transforms)

a.

b. (Active Transform -> Create
new LinearTransform)
c.

(Apply Transform -> select your data
set -> press the green arrow to move
it from Transformable to Transformed.)

d. (Rotation -> LR -> 90 degrees)

If this is done correctly, you will notice
your slice will change to be horizontal.

b.

c.

d.

Return to the Volume Rendering tab. Move the cropping sliders in the 3D view
to discover different elements within your data. Once your desired data has
been chosen, you can begin editing the colours. The colours need to be altered
to ensure they are bold when printed.

Guide to Bitmaps

d. COLOUR EDITING

(Drop down menu -> Sample Data -> Volume Rendering)

The first (and possibly second) points may need to be left as they are, depending
on the colour you’re trying to achieve. You will be able to see how the colours
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(Advanced -> Bring up all Scalar Opacity Mapping points)

change as you do this.
If you wish to change the colours in your model, change them under the Scalar

3 D Sli cer

Colour Mapping section.

e. MEASUREMENTS

The measurements of your model can be seen and altered, ensuring your
model is to the size you want.
(Advanced -> ROI)
Drag the toggles to see which side of the ROI (cropping tool) changes. These
also correspond to the colour sliders in the top right visualization.
The I-S is the thickness of the slice. Minus the smaller number from the larger
number for the thickness of your slice (in mm), and divide by 0.027 for the
number of slices that will be generated.
The P - A range must not have a difference of more than 40 as this is the width
of the J850 printing bed, it is is above 40 the print will be across
two print lines and the cost will be heightened.
The L - R range may be whatever you wish as this is the length from left to right.
If you want your model to include more vertical data than horizontal, go back
to step 3 and turn your data 90 degrees right.

f. EDITING YOUR DATA SET (CONTINUED)

Continue editing your data set until the section displayed is what you want to
capture. You may need to go between different steps until you are satisfied.
Any areas without colour can be printed with a clear material or without any
material, these steps are covered in the Guide To Voxel section of this book.

Once you are happy with your section, you can generate you Bitmaps.
(Drop down menu -> SlicerFab)

Guide to Bitmaps

g. BITMAP GENERATION

If SlicerFab is not an option, you will need to install it from the extensions
manager.
Once in the Bitmap Generator, both the X and Y resolutions need to be changed
to 150 DPI and the layer thickness needs to be set to 0.027mm. The scale should
be set to 1.000x.
Create a new folder where the generated images will be saved to, make sure it
is clearly named and you know the location of it.

After all layers have been generated using SlicerFab, decide upon how thick
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h. THICKNESS OF MODEL

you want your print to be as this determines how many images you need in
your print.
This was mentioned in step E. when scaling under ROI, but needs to be checked
before submitting for printing.
When choosing the amount of bitmaps, think about how many are needed for
the height you are wanting. Layers are printed at 0.027 mm high, so a height of
5 mm (approx.) is 186 images, and 10 mm high (approx.) is 370 images.
(number of bitmaps x 0.027 = height of print)
Once you know how many images you require, select that many from your
3 D Sli cer

total amount of image and put them into a new folder.

3. Tips and Tricks
• White will make your colours more opaque but less
transparent
• To make a transparent/translucent 3D print, it is
better to use vivid colours
• It is worthwhile testing this with your own prints
before printing the final model.

